Konstantstromquelle/Die4Drive Nachbau ohne SMD/TEC-Treiber

Selbstbau-Projekte aller Art.

Moderatoren: nohoe, lightwave, adminoli

Benutzeravatar
oli1212
Beiträge: 285
Registriert: Mi 11 Jun, 2008 2:18 pm
Wohnort: Hamburg

Beitrag von oli1212 » Mi 10 Sep, 2008 6:20 pm

Hi,

also ich meinte diese dioden hier,

http://cgi.ebay.de/150mW-405nm-Blue-Vio ... .m63.l1177


Folgende Werte:


Max Current: ~110mA
Avg. Lase Threshold: ~31mA
Avg. Lase Voltage: ~4 volts
Avg. Operating Voltage: ~5 volts


Wäre nett, wenn du mir die Werte ausrechnen könntest:) aber wissen wie man sie errechnet, wüsste ich auch sehr gern!

Benutzeravatar
equal
Beiträge: 91
Registriert: Di 04 Sep, 2007 12:29 pm
Wohnort: Essen
Kontaktdaten:

Beitrag von equal » Do 11 Sep, 2008 4:05 pm

Hallo oli1212,

ich habe mal, für eine Versorgungsspannung von 12V, sinnvolle Werte für R1 und R2 berechnet:

R1 -> 68kOhm (vorher 22kOhm) -> Offset
R2 -> 22kOhm (vorher 10kOhm) -> Gain

Es stellen sich dann die folgenden Ströme ein:

Offset -> 0mA - 80mA
Gain -> 0mA - 104mA

Der LD Strom ist immer Offset+Gain. Wenn beide Trimmer auf 50% stehen, hast du bei 0V Modulation ca. 40mA LD Strom und bei 5V Modulation ca. 92mA LD Strom.

Wo soll ich bei der Erklärung der Berechnung beginnen? Ist Dir klar das die Spannung über R7 immer gleich der Spannung über R4 ist und die Spannung über R7 bzw. R4 proportional (Verhältnis 1:1) zum LD Strom ist?

Gruß aus Essen ... Erik

Benutzeravatar
oli1212
Beiträge: 285
Registriert: Mi 11 Jun, 2008 2:18 pm
Wohnort: Hamburg

Beitrag von oli1212 » Fr 12 Sep, 2008 7:21 pm

Erstmal vielen Dank für die Berechnung :)


Hmmm... ja ich weiss noch genau ob mir das so klar ist:) vll könntest du dann damit beginnen...

EDIT: Ich fahr morgen für 2 Wochen in urlaub, also kann das noch warten:)

Benutzeravatar
orikson
Beiträge: 78
Registriert: Sa 06 Okt, 2007 10:35 am

Beitrag von orikson » Di 16 Sep, 2008 2:40 pm

Ich habe mich mal hingesetzt und meine 4 Platinen bestückt. Hier erst mal 2 Bilder von einer bestückten Platine, sieht sehr sauber und aufgeräumt aus, wie ich finde 8)
BildBild

Und dann hab ich die Treiber noch ein wenig mit einer High Power LED (3,4 V, 700 mA) gequält. Hier einige Messwerte:

Ströme

Stromverbrauch ohne Last: 2,3 mA

Kleiner Idle Strom:

Code: Alles auswählen

Leistung   Amperemeter     Monitoranschlüsse
Idle        19,53 mA           2,03 mV
100%        230 mA             23,5 mV
Größter möglicher Strom bei 5 Volt:

Code: Alles auswählen

Leistung   Amperemeter     Monitoranschlüsse
Idle        105,4 mA          10,4 mV
100%        300 mA            30,7 mV
Größter möglicher Strom bei 10 Volt:

Code: Alles auswählen

Leistung   Amperemeter     Monitoranschlüsse
Idle        220 mA          203 mV
100%        760 mA           577 mV
Die Differenzen bei 10 Volt müssen durch Widerstandswerte oder ähnliches angepasst werden, habs extra mit 2 Multimetern durchgemessen und bei beiden das selbe!

Hier sieht man einen Vergleich von Eingangs- und Ausgangsstrom. Das schwarze Netzteil misst den Strom im mA vor dem Treiber, das blaue den durch die Diode.
Bild

Dann habe ich die Versorgungsspannung des Treibers mal hochgedreht. Ab ca. 10 Volt werden 700 mA erreicht, wenn beide Trimmer voll aufgedreht sind.

Ein-/Ausschaltverhalten

Mich würden evtl. Peaks beim ein- und ausschalten sehr interessieren. Leider kann ich das nicht messen, da ich kein Oszi habe und auch keine Möglichkeit habe, an eins ran zu kommen. Wenn also wer da ein paar Bilder von machen könnte wäre ich ihm sehr verbunden und würde sie hier einfügen!

Temperaturen

Noch ein Wort zu den Temperaturen an den Bauteilen. Im 5 Volt Betrieb wird lediglich der Transistor ein wenig warm, aber selbst nach einer halben Stunde Volllast (300mA) ist der nur Handwarm, also unbedenklich. Der große Widerstand oder der OPA werden nicht warm.

Bei 10 Volt erhitzt sich der Transistor allerdings sehr schnell auf > 60°C. Das geht selbst beim Idlestrom schon sehr schnell, ein Kühlkörper ist hier also Pflicht!

Ich würde mich außerdem bereit erklären, den TEC Controller von equaL mal zu Routen und nachzubaun. Allerdings wäre ich froh, wenn mir da jemand eine Prototypen Platine beisteuern könnte, meine Ätzversuche gestern gingen gewaltig in die Hose dank des billigen Platinenmaterials von Reichelt; das nächste mal wieder Bungard Material, das hat immer super geklappt!

Benutzeravatar
elmex
Beiträge: 80
Registriert: So 13 Okt, 2002 12:00 pm
Wohnort: Seukendorf (Bayern)
Kontaktdaten:

Beitrag von elmex » Di 16 Sep, 2008 6:01 pm

@Orkison

ich könnte dir Platinen machen, wennst mir des Layout zur Verfügung stellst, oder wie weit bist mit dem Layout ?
Könnte mich ja auch noch mit hinsetzen und mal was zusammenrouten :)

MFG Sascha

Benutzeravatar
orikson
Beiträge: 78
Registriert: Sa 06 Okt, 2007 10:35 am

Beitrag von orikson » Sa 20 Sep, 2008 3:00 pm

@Elmex: Ok, danke schon mal für die Aufopferung, werde mich bei dir melden, sobald das ganze für OK befunden wurde.

Habe hier jetzt mal den Schaltplan nach Eagle übertragen und einige Bauteile rausgesucht. Erst mal der Schaltplan (hoffe ich hab keinen Leichtsinnsfehler drin :roll: ) :
Bild
3 Fragen hab ich dazu aber noch:
1) R5 hat ja 0,12 Ohm, allerdings konnte ich nur 5 Watt oder kleinere mit diesem Widerstand finden. Wird das auch für größere Peltiere reichen?
2) Die Spule L1 (ignoriert das !) sollte ja mindestens das aushalten, was der LM2546 maximal liefern kann (3 Ampere). Da habe ich mal die "FED 100µ" von Reichelt eingeplant.
3) Ansonsten hätte ich die beiden 100µF ElKos je gegen 2 x 47µF ElKos getauscht, um den ESR etwas runter zu bekommen, was bei Schaltreglern ja eigentlich wichtig ist. Oder ist es in diesem Fall vernachlässigbar?

Wenn außerdem irgendwer die Schaltung man vergleichen könnte, sowohl ob ich sie richtig von equaL nachgebaut habe als auch ob noch andere Fehler drin sind? Mir ist jetz nichts mehr aufgefallen. Wenns n OK gibt, route ich das Teil mal.

Benutzeravatar
equal
Beiträge: 91
Registriert: Di 04 Sep, 2007 12:29 pm
Wohnort: Essen
Kontaktdaten:

Beitrag von equal » So 21 Sep, 2008 9:24 pm

Hallo Orikson,

was den Shunt Widerstand [R1] angeht, so sind 5 Watt Belastbarkeit mehr als ausreichend. Mit den angegebenen Werten für [R1;R2;R3] wird der Peltier Strom auf knapp 2A fest eingestellt. Damit gilt für die Verlustleistung über R1 -> P=I*I*R1=0,48W.

Was die Speicher Drossel und den Kondensator angeht, so schaue am besten in das Datenblatt des Schaltreglers. Dort werden Dimensionierungsvorgaben gegeben. Die angegebenen Werte sind aus dem Applikationsvorschlag des Datenblatts. Die Werte sind für die meisten Anwendungsfälle geeignet, bieten aber nicht den höchstmöglichen Wirkungsgrad.

http://cache.national.com/ds/LM/LM2576.pdf

Gruß aus Essen

Erik

goamarty
Beiträge: 1488
Registriert: Fr 05 Sep, 2008 10:15 am
Do you already have Laser-Equipment?: 190mW RGY + einige Module
Wohnort: Wien

Dioden

Beitrag von goamarty » So 21 Sep, 2008 11:02 pm

Mir fällt auf, das hier als Ersatz für BAV99 2*BAV21 genommen werden. Sind aber nicht gleich, die BAV21 ist mehr als 10mal langsamer (Sperrverzögerungszeit) - auch wenn das hier eher egal ist. Die BAV99 entspricht viel mehr einer doppelten 1N4148 - und die gibt es "an jeder Ecke". Deswegen muß man sich nicht (aus Österreich) mit reichelt herumquälen.
Für langsame Sachen (LED, Peltier) reicht auch in der LM2576 Schaltung ein LM358. AD820 ist doch etwas teuer (Analog Devices hlt - gut aber teuer).

Benutzeravatar
orikson
Beiträge: 78
Registriert: Sa 06 Okt, 2007 10:35 am

Beitrag von orikson » Mo 22 Sep, 2008 11:19 am

equaL hat geschrieben:was den Shunt Widerstand [R1] angeht, so sind 5 Watt Belastbarkeit mehr als ausreichend. Mit den angegebenen Werten für [R1;R2;R3] wird der Peltier Strom auf knapp 2A fest eingestellt. Damit gilt für die Verlustleistung über R1 -> P=I*I*R1=0,48W.
Ok, habe mitlerweile gesehen, dass auf deinem Schaltplan die entsprechenden Formel drauf ist. Demnach könnte man den Ausgangstrom auf ca. 2,92 Watt erhöhen, wenn man R2 auf 40k Ohm verändert. R1 bleibt bei 0,12 Ohm und müsste dann etwas über 1 Watt verbraten, ein 2 Watt Widerstand reicht also dicke aus.
goamarty hat geschrieben:Mir fällt auf, das hier als Ersatz für BAV99 2*BAV21 genommen werden. Sind aber nicht gleich, die BAV21 ist mehr als 10mal langsamer (Sperrverzögerungszeit) - auch wenn das hier eher egal ist. Die BAV99 entspricht viel mehr einer doppelten 1N4148 - und die gibt es "an jeder Ecke".
Simmt, warum hab ich das nicht vorher gesehen. :roll:
goamarty hat geschrieben:Für langsame Sachen (LED, Peltier) reicht auch in der LM2576 Schaltung ein LM358. AD820 ist doch etwas teuer (Analog Devices hlt - gut aber teuer).
Außerdem wäre der LM358 gleich ein doppelter OPA, somit spart man sich ein Bauteil. Werde mir das Teil mal ansehen

Benutzeravatar
equal
Beiträge: 91
Registriert: Di 04 Sep, 2007 12:29 pm
Wohnort: Essen
Kontaktdaten:

Beitrag von equal » Mo 22 Sep, 2008 10:22 pm

Hallo Orikson,

eins ist mir noch aufgefallen ... für C2 sagt das Applikationsschaltbild 1000uF und nicht 100uF.

Gruß aus Essen ... Erik

Benutzeravatar
alex20q90
Beiträge: 108
Registriert: So 05 Nov, 2006 3:24 pm

Beitrag von alex20q90 » Di 23 Sep, 2008 4:43 pm

Sollte das Peltier keinen Gleichstrom bekommen, so kannst die Regelung gleich vergessen!

Die Wärme die beim Einbruch der Spannung von warm nach kalt wandert, macht über kurz oder lang das Peltier-Element kaputt!

Ich würde anstatt eines LM2576 lieber ein LM338 als Konstantstromregler bzw als Konstantspannungsregler einsetzen und über den AD820 den Ausgangsstrom/Spannung zum Peltier regeln!

Die momentane Ansteuerung macht ja nix weiteres als EIN / AUS Ist wirklich schlecht für das Peltier-Element!

Grüße
Alex

Benutzeravatar
equal
Beiträge: 91
Registriert: Di 04 Sep, 2007 12:29 pm
Wohnort: Essen
Kontaktdaten:

Beitrag von equal » Di 23 Sep, 2008 7:41 pm

Hallo Alex,

ja, mit einem Längsregler geht es auch - hierzu 3 Fragen:

1. Wie soll der Ausgangsstrom beim Erreichen der Solltemperatur abgeschaltet werden? Das Minimum der Ausgangsspannung des LM338 liegt bei 1,2V.

2. Hast Du einen Schaltungsvorschlag?

3. Kannst Du die folgende Aussage begründen?
Die Wärme die beim Einbruch der Spannung von warm nach kalt wandert, macht über kurz oder lang das Peltier-Element kaputt!
Gruß aus Essen ... Erik

Benutzeravatar
orikson
Beiträge: 78
Registriert: Sa 06 Okt, 2007 10:35 am

Beitrag von orikson » Mi 22 Okt, 2008 10:00 pm

So, hier mal das erste Layout mit einem LM358:
Bild

Im Anhang auch die Eagle Files. Da das der erste Entwurf ist bitte ich jemanden (wer will) mal eben nochmal drüber zu schauen, ob es den noch wo ein Problem gibt. Die Leiterbahndicke liegt an den Lastteilen (also da, wo fast 3 Ampere fließen) bei 1,3 - 1,44 mm, mehr habe ich Platztechnisch nicht untergebracht. Das heißt, bei 35µm Kupferauflage würden sich die Leiterbahnen an den Stellen um ca. 15°C erwärmen, maximal jedoch um fast 30°C.

Wie sieht das denn mit den Schwingungen der Teile aus? Kann ich die Leiterbahn einfach unter der Spule durchlaufen lassen oder stört das?

An Stelle von einem großen ElKo verwende ich hier immer 2 halb so große, parallel geschalten. Dadurch wird der ESR runtergesetzt, was meines Wissens bei Schaltreglern recht wichtig ist.

EDIT: Man beachte das Inhaltsverzeichnis im ersten Post. Ich fände es klassen, wenn man den Post sticky machen könnte, da sich hier doch schon einige interessante Schaltungen angesamelt haben!
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Benutzeravatar
peter_rgb
Beiträge: 15
Registriert: So 23 Sep, 2007 7:36 pm
Wohnort: Regensburg/Landshut

Beitrag von peter_rgb » Fr 31 Okt, 2008 9:51 pm

Hi!

Echt ein sehr interessanter Thread, auch wenn ich mich ziemlich aufs Mitlesen beschränken muss (wegen der nicht tief genug gehenden elektronischen Ahnung...)-Aber ein Riesen Lob an die aktiven Entwickler der hier geposteten Schaltungen!

Eigentlich hab ich nur eine kurze Frage, Elmex hat weiter vorne ein Layout des Treibers mit Steckern erwähnt -Es wäre sehr nett, wenn das jemand posten könnte -vielen Dank schon mal!

(Würde mir den Treiber nämlich auch gern bauen, hab im Moment gerade den 'relativ aufwändigen ttl-Treiber' vom ersten Post im Einsatz ;) )

Viele Grüße
Peter

Benutzeravatar
orikson
Beiträge: 78
Registriert: Sa 06 Okt, 2007 10:35 am

Beitrag von orikson » Sa 01 Nov, 2008 7:38 pm

Die ersten Platinen sind gemacht! Die Quali lässt aber seht zu wünschen übrig, da ich mich mal an der Tonertransfermethode versucht habe. Irgendwie löst sich bei mir aber das Papier nicht 100% und kleine Leiterbahnen sind sehr kritisch...
Bild

Als Prototyp sollte es aber reichen, jetz brauch ich nur noch die Bauteile :roll:

Benutzeravatar
elmex
Beiträge: 80
Registriert: So 13 Okt, 2002 12:00 pm
Wohnort: Seukendorf (Bayern)
Kontaktdaten:

Beitrag von elmex » So 02 Nov, 2008 11:22 am

@ Peter_rgb und auch alle anderen...

hier nun die Eagle-Dateien als 1-fach und 2-fach Version...
Bevor Fragen aufkommen... die LED neben der Spannungsversorgung hab ich gleich als 5V-LED mit integriertem Widerstand verbaut, war günstiger :) und hat auch Platz gespart...

sooo, dann mal viel Spaß mit den Dateien und bei Fragen einfach fragen...

MFG Sascha
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Zuletzt geändert von elmex am Fr 19 Dez, 2008 10:27 pm, insgesamt 1-mal geändert.

werner_b
Beiträge: 303
Registriert: Sa 16 Feb, 2008 11:36 am
Do you already have Laser-Equipment?: 658 LOC, 642, 532, 457, 445,
Wohnort: Vorderpfalz

Beitrag von werner_b » So 02 Nov, 2008 12:41 pm

Auch von mir noch mal ein herzliches Dankeschön alle, die produktiv was beigetragen haben.
Wenn es nur überall so reibungs-, und neidlos zugehen würde. . .

Mit der Tonermethode habe ich gute Erfahrungen gemacht. In der Tat kommt es auf das Papier an. Den Reicheltkatalog (als Papier) kann ich sehr empfehlen.

Für die, die es noch nicht kennen:

http://thomaspfeifer.net/

Gruß

Werner
Gruß

Werner

Benutzeravatar
far
Beiträge: 152
Registriert: Do 17 Jan, 2008 6:27 pm
Wohnort: Hannover/Celle

Beitrag von far » Sa 15 Nov, 2008 1:16 pm

Hallo,

ich bin leider erst jetzt auf diesen Thread gestoßen.

Hab mal eine Frage und zwar hat schon jemand Erfahrungen mit dem
"TEC Treiber"?

Gruß Far

Benutzeravatar
orikson
Beiträge: 78
Registriert: Sa 06 Okt, 2007 10:35 am

Beitrag von orikson » Sa 15 Nov, 2008 6:09 pm

Far hat geschrieben:Hab mal eine Frage und zwar hat schon jemand Erfahrungen mit dem "TEC Treiber"?
Ich vermute nicht. Aber ich schätze diese Woche sollten die Bauteile bei eintreffen, dann kann ich den schon mal rudimentär testen, wäre schön wenn sich jemand mit Oszi melden würde. Dann würde ich dem eine bestückte Platine zukommen lassen, die er dann mal Durchtesten und quälen kann.

Benutzeravatar
equal
Beiträge: 91
Registriert: Di 04 Sep, 2007 12:29 pm
Wohnort: Essen
Kontaktdaten:

Beitrag von equal » So 16 Nov, 2008 1:10 pm

Hallo Orikson,

da es nun wohl losgeht möchte ich Dir folgendes zur Funktion der Temperaturregelung sagen:

Es handelt sich hier um eine klassische Wheatstonesche Messbrücke mit Hysterese. Die Kennlinie des KTY81-210 ist recht linear. Die Widerstandsänderung beträgt ca. 15 Ohm pro Grad. Hier ein Auszug aus der Kennlinie:

0 Grad <> 1630 Ohm
10 Grad <> 1772 Ohm
20 Grad <> 1922 Ohm
30 Grad <> 2080 Ohm

Mit dem 1 kOhm Poti stellst Du die Solltemperatur ein. Also z.B. 12 Grad - das entspricht 1400+402 Ohm. Die Hysterese kannst Du mit dem 500 kOhm Poti zwischen 600 kOhm und 100 kOhm einstellen. Die Widerstandsänderung am Spannungsteiler beträgt ca.:

1900-(1/((1/1900)+(1/600000)))=6 Ohm (bei 600 kOhm)

und

1900-(1/((1/1900)+(1/100000)))=35 Ohm (bei 100 kOhm)

Die Hysterese Schaltpunkte liegen dann ca. bei:

1808 Ohm und 1796 Ohm - 12.4 Grad und 11.6 Grad (bei 600 kOhm)

und

1837 Ohm und 1767 Ohm - 14.3 Grad und 9.7 Grad (bei 100 kOhm)

Dieses Verhalten kannst Du auch mit einem Spannungsmesser nachvollziehen. Ein Oszilloskop ist nur notwendig um zu prüfen ob die Spannung am Peltier Element frei ist von der Schaltwechselspannung des Schaltreglers.

Ich habe nur ein sehr einfaches 20MHz Oszilloskop - dessen Verwendung ich Dir aber gerne anbiete ... wo wohnst Du?

Gruß aus Essen ... Erik

Benutzeravatar
Gooseman
Beiträge: 468
Registriert: So 12 Okt, 2003 4:16 pm
Wohnort: HB
Kontaktdaten:

Beitrag von Gooseman » So 16 Nov, 2008 1:58 pm

Hallo,
warum baut ihr da immer als Shunt eine 1Ohm 5Watt ein (1Ohm ist klar)
aber warum 5Watt ? selbst 1Watt ist bei z.B. 280mA zuviel.
Oder hab ich da irgendwas übersehen warum da 5Watt rein müssen ?
Mein D4d ohne SMD läuft mit 1W.
Ciao!
Gooseman

Benutzeravatar
equal
Beiträge: 91
Registriert: Di 04 Sep, 2007 12:29 pm
Wohnort: Essen
Kontaktdaten:

Beitrag von equal » So 16 Nov, 2008 8:25 pm

Du hast nichts übersehen. Für den Anwendungszweck reicht ein 1 Watt Widerstand locker aus. Auch ein 1/2 Watt Widerstand wird reichen.

Die Verlustleistung am Shunt verhält sich quadratisch zum LD Strom.

P=I*I*R

300 mA <> 90 mW
500 mA <> 250 mW
1000 mA <> 1 W
2000 mA <> 4 W

Wenn man im Layout Platz für einen 5 Watt Widerstand lässt - erhält man ein universelles Design welches auch mit potenteren IR Dioden klar kommt. Wenn man daran dann eine rote LD mit 250 mA betreibt hat man auch keinen Nachteil, ausser dem erhöhten Platzverbrauch. Hauptsache man verwendet einen Schichtwiderstand und keinen Drahtwiderstand.

Gruß aus Essen ... Erik

Benutzeravatar
orikson
Beiträge: 78
Registriert: Sa 06 Okt, 2007 10:35 am

Beitrag von orikson » Di 18 Nov, 2008 8:34 pm

equaL hat geschrieben:Ich habe nur ein sehr einfaches 20MHz Oszilloskop - dessen Verwendung ich Dir aber gerne anbiete ... wo wohnst Du?
Ein einfaches ist immernoch besser als gar keins :lol: Aber da wird die Entfernung wohl etwas zu weit sein, ich komm aus der Oberpfalz, Grafenwöhr und die Postleitzahl ist 92655.

Einen Screen vom Oszi würde ich auch nur wollen um zu sehen, wie glatt die Spannung ist, die am Peltierelement anliegt. Zur Zeit warte ich aber noch auf Teile

Benutzeravatar
equal
Beiträge: 91
Registriert: Di 04 Sep, 2007 12:29 pm
Wohnort: Essen
Kontaktdaten:

Beitrag von equal » Di 18 Nov, 2008 8:58 pm

Hmm ... stimmt. Vor kurzem hätte man für die Fahrtkosten noch ein Oszilloskop kaufen können ...

Bin gespannt wie sich der Schaltregler in deinem Layout bewährt. Der Horror wäre wenn Spannungsspitzen vom Schaltregler die Temperaturregelung stören. Aber dafür könnte man Abhilfe schaffen wenn es notwendig ist ...

Gruß aus Essen ... Erik

Benutzeravatar
orikson
Beiträge: 78
Registriert: Sa 06 Okt, 2007 10:35 am

Beitrag von orikson » Mi 19 Nov, 2008 10:07 pm

So, Teile sind heute gekommen und hab auch gleich mal einen Treiber gelötet. Soweit alles bestens, habe aber bislang noch keine Zeit gehabt das ganze fein einzustellen, nur den Trimmer für die Temperatur mal runter gedreht und getestet. Hier aber erst mal Bilder:
BildBild

In der Einstellung wie se gerade ist kühlt er Anfangs auf ca. 7°C runter, dafür braucht er ca. 20 Sekunden und zieht bei 5 Volt ca. 1,5 A. Mein Peltier ist eigentlich für 6 Volt und 3 Ampere gedacht. Wenn die Temperatur erreicht ist schaltet er für ca. 10 Sekunden ab und die temperatur geht wieder hoch bis 14°C bevor er wieder anschaltet. Mit der Zeit hat sich das dann bei ~11°C eingependelt. Das wird fürs Petlier nicht das beste sein, aber wie gesagt: An der Hysterese hab ich noch nicht gedreht.

Der LM2576 wurde dabei ganz schön heiß (60°C wenn nicht noch mehr) weshalb ich ihm die beiden kupferbeschichteten Platinen umgeschnallt habe. Außerdem pfeift es, sobald gekühlt wird kurz, dann ist es aber still bis er das nächste mal wieder einschaltet...

Das ganze sieht zwar etwas abenteuerlich aus, ich habe aber auf die Schnelle nix besseres gefunden. Der "Kühlturm" besteht aus nem 0815 Alukühler auf dem die warme Seite des Peltier liegt. Fixiert ist das mit einer Pinzette :roll: Dann kommt ein Wärmeleitpad, der Temperaturfühler meines Thermometers, noch ein Wärmeleitpad und der Thermofühler vom Treiber. Oben sind dann noch 2 Traffos für etwas Anpressdruck.

Wenn sich jemand bereit erklärt das Teil an ein Oszi zu hängen kann ich noch die 2te Platine machen und dem jenigen zuschicken. Entweder 4 free, dann wäre es aber nett den Treiber wieder zu bekommen oder gegen die Bauteilkosten (mit Vergünstigung, da derjenige ja dann mithilft) und kann ihn dann behalten!

EDIT: Das Geschwisterchen ist jetzt auch fertig :roll:
BildBild
Wie zu erwarten funktioniert auch der. Die schwarzen Flechen sind noch Toner, ich bin da immer zu faul den wegzuschleifen :P

EDIT 2: Was ich euch nicht vorenthalten möchte ist folgende Antwort von peltron.de auf meine Frage, ob das ständige an- und ausschalten einem Peltier schaden kann:
Ja, das ständige Ein- und Ausschalten stresst das Peltierelement, so dass sich seine Lebenserwartung verkürzt. Der Grund liegt in der Sprödigkeit der Wismuttelluridkristalle und der Wärmeausdehnung der Materialien.

Deshalb wäre ein Stetigregler optimal, wie z.B. unsere PRG H100, siehe Anhang.

Wenn das zu teuer ist, wäre der Kompromiss ein PWM-Regelgerät, das mit einer möglichst hohen Pulsfrequenz arbeitet. (Es muss sich um Rechteckpulse handeln).

In wieweit ein Kondensator für die Lebenserwartung nützlich ist, hängt von der Pulsfrequenz bzw. der damit erreichten Restwelligkeit ab.

Benutzeravatar
equal
Beiträge: 91
Registriert: Di 04 Sep, 2007 12:29 pm
Wohnort: Essen
Kontaktdaten:

Beitrag von equal » Sa 22 Nov, 2008 11:20 am

Der Hinweis auf die mechanische Belastung des Halbleitermaterials ist nachvollziehbar. Wenn dieser Effekt die Lebensdauer des Elements merkbar beeinflusst ist das vorliegende Konzept "Zweipunktregler" nicht wirklich brauchbar. Sollte man noch mal über eine kontinuierliche Regelung nachdenken? Mit Spezialbauteilen von Linear Technologie ist das eigentlich kein Problem. Diese Spezial IC's haben allerdings alle schlecht zu montierende Gehäuse - und scheiden damit aus meiner Sicht aus. Was ich gerade durchdenke ist eine kontinuierliche Regelung mit dem auch jetzt verwendeten Schaltregler. Man muss die Spannungsverstärkung der Stromgegenkopplung abhängig machen von der Temperaturdifferenz zwischen Soll- und Isttemperatur. Bis jetzt hab ich nur wildes geschmiere auf dem Papier - mal sehen ...

Gruß aus Essen ... Erik

goamarty
Beiträge: 1488
Registriert: Fr 05 Sep, 2008 10:15 am
Do you already have Laser-Equipment?: 190mW RGY + einige Module
Wohnort: Wien

Beitrag von goamarty » Sa 22 Nov, 2008 3:45 pm

Den Toner würde ich eher drauflassen, schützt das Kupfer vor Oxydation, so wie er es vor der Ätze geschützt hat. Wenn er dir nicht gefällt, dann eher mit Lösungsmittel (Reinigungsbenzin) entfernen, damit wird das Kupfer nicht so zerkratzt, ist ja nur 35µ dick und an den Kratzern oxydiert es auch leichter (große Oberfläche).
Ich würde keine Zweipunktregelung machen, sondern auf jeden Fall kontinuierlich, das heißt, keine Hysterese sondern einen linearen Regelverstärker mit ausreichend kleiner Verstärkung, damit er nicht schwingt.
Eine PWM Regelung hat fast soviel Verlsut, wie eine lineare Regelung, aber die Verlustleistung wird im Peltier umgesetzt -> schlecht. Zweipunkt ist da eigentlich nichts besser.
Nachdem ein Peltier selbst eine Temp.abhängige Spannung erzeugt kann man es vermutlich stabiler über die Spannung regeln und nicht mit Konstantstrom. Nur könnte an den Rückkopplungseingang des LM2576 kein einfacher Spannungsteiler kommen, sondern ein temperaturabhängiger.

Benutzeravatar
equal
Beiträge: 91
Registriert: Di 04 Sep, 2007 12:29 pm
Wohnort: Essen
Kontaktdaten:

Beitrag von equal » So 23 Nov, 2008 1:24 am

Hallo goamarty,

schön das Du dich hier einbringen möchtest. Du hast bei einigen Punkten nicht ganz das Thema getroffen hast ... da möchte ich Abhilfe schaffen.

goamarty -> "Eine PWM Regelung hat fast soviel Verlsut, wie eine lineare Regelung, aber die Verlustleistung wird im Peltier umgesetzt -> schlecht."

In diesem Thread geht es um einen DC-DC Konverter dessen Spannung über einen Regelverstärker gesteuert wird. Grundlage der Gegenkopplung ist der Strom durch das Peltier Element. Schaltverluste am Peltier Element sind daher kein Thema.

goamarty -> "Zweipunkt ist da eigentlich nichts besser."

Das Thema "Zweipunktregelung oder kontinuierliche Regelung" ist davon unabhängig. Dieses Thema beinflusst vor allem die mechanische Belastung des Peltier Elements.

goamarty -> "Nachdem ein Peltier selbst eine Temp.abhängige Spannung erzeugt kann man es vermutlich stabiler über die Spannung regeln und nicht mit Konstantstrom."

Eine Vermutung kann leider nicht Grundlage einer Schaltungsentwicklung sein. Hast Du Informationen über die Anwendbarkeit einer Spannungsregelung bzw. einer Stromregelung für Peltier Elemente?

goamarty -> "Nur könnte an den Rückkopplungseingang des LM2576 kein einfacher Spannungsteiler kommen, sondern ein temperaturabhängiger."

Ein "könnte" ist zur Schaltungsentwicklung wenig geeignet. Hast Du einen konkreten Vorschlag?

Gruß aus Essen ... Erik

goamarty
Beiträge: 1488
Registriert: Fr 05 Sep, 2008 10:15 am
Do you already have Laser-Equipment?: 190mW RGY + einige Module
Wohnort: Wien

Beitrag von goamarty » So 23 Nov, 2008 1:54 am

Die Zweipunktregelung erzeugt letztlich eine langsame PWM - daher der Bezug, ich hab gesehen, daß ein DC/DC Konverter gebaut wurde, aber mit einem konstanten, nicht temperaturabhängigen Strom.
"Sollte" und "könnte": Verzeihe, daß ich keine komplette Treiberschaltung gepostet habe, ich hatte lediglich ein paar Ideen, die der Entwickler der Schaltung berücksichtigen und ausprobieren kann.
Liebe Grüße,
Martin

Benutzeravatar
orikson
Beiträge: 78
Registriert: Sa 06 Okt, 2007 10:35 am

Beitrag von orikson » So 23 Nov, 2008 5:56 pm

goamarty hat geschrieben:Die Zweipunktregelung erzeugt letztlich eine langsame PWM - daher der Bezug, ich hab gesehen, daß ein DC/DC Konverter gebaut wurde, aber mit einem konstanten, nicht temperaturabhängigen Strom.
Ich möchte nochmal darauf hinweisen, dass die Hysterese nicht verändert habe, diese ist zur Zeit so eingestellt, das die Schaltung relativ langsam an und ab schaltet.

Wir werden sehen, wie weit man diese hochdrehen kann und wie "glatt" die daraus entstehende Spannung wird (Päckchen geht am Montag zu einem Oszi Besitzer raus, danke an der Stelle nochmal :roll: ).

Benutzeravatar
equal
Beiträge: 91
Registriert: Di 04 Sep, 2007 12:29 pm
Wohnort: Essen
Kontaktdaten:

Beitrag von equal » So 23 Nov, 2008 7:33 pm

Hallo goamarty,

da hab ich wohl etwas heftig reagiert. Ausgehend von meiner vorherigen Aussage:

Man muss die Spannungsverstärkung der Stromgegenkopplung abhängig machen von der Temperaturdifferenz zwischen Soll- und Isttemperatur.

denke ich schon Stunden über eine Lösung nach. Die Lösung muss folgendes leisten:

Bei der Solltemperatur (der PTC hat dann ca. 1800 Ohm) soll die Spannungsverstärkung des Regelverstärkers >= 400 sein. (der Strom durch das Peltier Element beträgt dann 30 mA)

Ab Solltemperatur + 10 Grad (der PTC hat dann ca. 1950 Ohm) soll die Spannungsverstärkung des Regelverstärkers = 5 sein. (der Strom durch das Peltier Element beträgt dann 2 A)

Zwischen den beiden Temperaturen soll die Spannungsverstärkung proportional zur Widerstandsänderung sein.

Ideen ???

Gruß aus Essen ... Erik

goamarty
Beiträge: 1488
Registriert: Fr 05 Sep, 2008 10:15 am
Do you already have Laser-Equipment?: 190mW RGY + einige Module
Wohnort: Wien

Beitrag von goamarty » So 23 Nov, 2008 9:50 pm

Ideen: Ein Analogmultiplizierer könnte funktionieren. Die relative Änderung von 1800 auf 1950 Ohm ist zu klein (zumindest weis ich jetzt keine solche Lösung), um den PTC direkt im Rückkopplungsspannungsteilers des Regelverstärkers einzusetzen.

Ideen:
Ein Analogmultiplizierer würde funktionieren. Mit einem OTA könnte das auch möglich sein.

Vielleicht muß man die Verstärkung auch gar nicht ändern sondern bei konstanter Verstärkung eine temperaturabhängige Spannung auf den Rückkopplungseingang (FB) hinzuadieren. Im einfachste Fall den Rückkopplungseingang mit einem Spannungsteiler aus Festwiderstand und PTC beschalten und die Ausgangsspannung des Strommeßverstärkers über einen Widerstand dazuhängen.
Also (stabile 10V Referenz)- PTC - (FB) - 1k8 - (GND). Das gibt 5V bei R(PTC)=1k8 und 4,8V bei R(PTC)=1950. Der Spannungsteiler hat dann eine Impedanz von 1k8 parallel 1k95 = 936 Ohm. Der Stromverstärker muß dann in den Knoten FB einen Strom von 213µA bei 2A Ausgangsstrom treiben, Also eine Verstärkung von etwa 0,0001 haben.

Wenn du deinen Shunt masseseitig hast (?), also: (LM2576 Ausgang) - Peltier - Shunt - (GND), dann kannst du ihn mit 0,1Ohm auslegen und den 1k8 statt an GND an den Minusanschluß des Peltiers hängen, also an den Knoten Peltier - Shunt. Die temperaturabhängige Spannung von 4,8 bis 5V und die stromabhängige (0 - 0,2V) addieren sich dann von selbst. Der Regelkreis ist geschlossen. Der Strom des Spannungsteilers von 2,5mA durch den Shunt verursacht einen Fehler von etwa 0,001 des Stromsollwertes.

Grüße Martin

Benutzeravatar
equal
Beiträge: 91
Registriert: Di 04 Sep, 2007 12:29 pm
Wohnort: Essen
Kontaktdaten:

Beitrag von equal » Mo 24 Nov, 2008 1:21 pm

Hallo Freaks, Hallo Martin,

ausgehend von den Überlegungen von goamarty habe ich eine Lösung für eine kontinuierliche PTC TEC Regelung gefunden. Ein Differenzverstärker erzeugt eine Spannung die positiv proportional zur Differenz zwischen Ist- und Solltemperatur ist. Diese Spannung wird mittels einem Komparator mit der Spannung über dem Shunt verglichen. Ist die Spannung über dem Shunt kleiner, so wird die Regelspannung auch niedriger. Damit erhöht der Schaltregler die Pulsweite und der Strom durch den Shunt wird größer.

Eine Simulation mit NI Multisim offenbarte eine gewisse Schwingneigung - deshalb die Kondensatoren welche die Schwingneigung zumindest in der Simulation wirksam verhindern.

Ich bitte alle Freaks den Vorschlag mal zu verifizieren ...

Gruß aus Essen ... Erik
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

goamarty
Beiträge: 1488
Registriert: Fr 05 Sep, 2008 10:15 am
Do you already have Laser-Equipment?: 190mW RGY + einige Module
Wohnort: Wien

Beitrag von goamarty » Mo 24 Nov, 2008 2:48 pm

C1 ist gut und richtig um Schwingneigungen zu unterdrücken. C2 erscheint mir überflüssig. C3 wandelt den Komparator zum Integrator um, was sehr gut ist, weil ein Komparator wieder ein Zweipunktregler wäre, das ganze würde gezwungenermaßen schwingen, möglicherweise mit einer Frequenz, die mit der Schaltfrequenz interferiert. Allerdings gehört in die Leitung vom Potischleifer von R13 noch ein Widerstand, damit die Integrationszeitkonstante nicht zusehr von der Stellung von R13 abhängig wird und insbesondere in den Endstellungen von R13 nicht gegen Null geht. Sonst hängt die Stabilität der Regelung von der Stellung von R13 ab.
Vermutlich muß die Integrationszeitkonstante aber deutlich größer gemacht werden, damit nicht die Regelung über alles schwingt. Ich bein kein Regeltechniker, aber es erscheint mir logisch, daß die Zeitkonstante eines Integralreglers deutlich größer sein muß als die thermische Zeitkonstante der Anordnung. Ein Proportionalregler ist stabiler, aber regelt nicht auf eine Sollwertabweichung von Null. Anspruchsvolle (Temperatur)regelungen verwenden PID Regler.

Benutzeravatar
equal
Beiträge: 91
Registriert: Di 04 Sep, 2007 12:29 pm
Wohnort: Essen
Kontaktdaten:

Beitrag von equal » Di 25 Nov, 2008 2:04 pm

Du hast völlig Recht. Nach etwas Recherche bin ich zur Überzeugung gelangt, dass die Anwendung eines PID Reglers notwendig ist. Scheint ja nicht gerade ein einfaches Thema zu sein ...

Vielleicht kann ich den Reglerteil aus dieser Schaltung anwenden ...

http://www.repairfaq.org/sam/sgtm1sch.pdf

Gruß aus Essen ... Erik

Antworten

Zurück zu „Allgemeine Selbstbau-Projekte“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 13 Gäste