CNI PSU-III-OEM OP-Amp wird heiß

Betrieb, Bau und Modifikation von Festkörper- und Diodenlasern (keine Pointer)
Antworten
Benutzeravatar
brathähnchen
Beiträge: 19
Registriert: So 20 Mai, 2007 7:45 pm

CNI PSU-III-OEM OP-Amp wird heiß

Beitrag von brathähnchen » Do 29 Mär, 2018 3:13 am

Hallo zusammen,

zufällig ist beim drübergucken mit der Wärmebildkamera aufgefallen, dass auf dem Treiber für den CNI DPSS der AD8606 (U1) am Powerstecker ordentlich warm wird. Ist das ein Defekt oder gehört das so?

Der Laserkopf ist ein MGL-III-FS-532-300mW, der Treiber dürfte eine PSU-III-OEM Variante sein. Der Laserkopf wird mit einem 15pol HD-Sub Stecker verbunden. Die PCB hat ein coating und lässt sich schlecht ablichten:
CNI_Driver_1.jpg
Immerhin sind hier 4 von 5 Trimmern beschriftet (ein weiterer Trimmer sitzt unter dem Stecker zum Laser):
CNI_Driver_trimpot.jpg
Der Laser funktioniert und bringt 255mW CW (mit IR gemessen) bzw. 243mW grün(ohne IR). Lediglich die Lüfterdrehzahl nimmt hörbar ab, wenn der Laser angesteuert wird.

Also Treiber nochmal ausgebaut und untersucht. Leider habe ich gerade nur eine einfache Wärmebildkamera (Seek compact) zur Verfügung, reicht aber um das fehlerhafte Bauteil zu finden. Im Betrieb werden ~100°C gemessen:
AD8606_Thermal_1.jpg
Leider gibt es bei der einfachen Kamera keine Einstellmöglichkeiten, wenn der Treiber abgeschaltet wird und die Restwärme betrachtet, sieht man etwas mehr:
AD8606_Thermal_2.jpg
Das coating hat sich durch die Temperatur bereits verfärbt:
AD8606_1.jpg
Coating entfernt, gleiche Ansicht wie die Wärmebildaufnahme:
AD8606_2.jpg
Hier https://www.laserfreak.net/forum/viewt ... 25&t=49377 hat es wohl auch Probleme mit dem AD8606 gegeben, allerdings sieht der Treiber anders aus. Einfach den OP-Amp tauschen würde ich ungern, ohne zu wissen warum er abgeraucht ist. Ausgang Out A (Pin 1) des AD8606 geht über 680 Ohm an den Shunt im TO220-Gehäuse, welche Funktion das hat kann ich mir nicht erklären.
Ausgang Out B (Pin 7) ist High-Z und geht direkt (ohne Vorwiderstand) an die Basis des NPN-Transistors U3 (im SOT-23 Gehäuse). Im schlechtesten Falle könnte der OP natürlich dort ordentlich Strom treiben und warm werden. Allerdings möchte ich ungern im Betrieb messen, bevor ich die Funktion genau kenne.

Grüße
Brathähnchen
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Benutzeravatar
Hatschi
Beiträge: 3450
Registriert: Mi 13 Mär, 2002 12:00 pm
Wohnort: Kaernten/Austria
Kontaktdaten:

Re: CNI PSU-III-OEM OP-Amp wird heiß

Beitrag von Hatschi » Do 29 Mär, 2018 5:48 am

Halli Hallo
brathähnchen hat geschrieben:
Do 29 Mär, 2018 3:13 am
Die PCB hat ein coating und lässt sich schlecht ablichten:
Schaltest du den Blitz aus, nimmst eine exterene Lichtquelle (Tischlampe) und schaust was der beste Einfallswinkel ist...

Hatschi

Benutzeravatar
brathähnchen
Beiträge: 19
Registriert: So 20 Mai, 2007 7:45 pm

Re: CNI PSU-III-OEM OP-Amp wird heiß

Beitrag von brathähnchen » Do 29 Mär, 2018 3:53 pm

Hatschi hat geschrieben:
Do 29 Mär, 2018 5:48 am
Schaltest du den Blitz aus, nimmst eine exterene Lichtquelle (Tischlampe) und schaust was der beste Einfallswinkel ist...
Oder man verlegt die Bastelei einfach auf "normale" Zeit und nimmt das Tageslicht :D

Werde wohl doch noch etwas Zeit zum Reverseengineeren des AD8606-Schaltungsteil investieren. Noch scheint der OP-Amp nicht durchlegiert zu sein, vielleicht gehört das tatsächlich so...
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Benutzeravatar
tracky
Beiträge: 4757
Registriert: Di 11 Mär, 2003 1:51 pm
Do you already have Laser-Equipment?: RGB Projektor mit 2W 445nm, 1W 520nm, 1W 658nm Swisslas, Raytrack 30, Gento Safety für Grafik Shows
2x Venus 1800 RGB
2x Venus 3 RGB
2x Eigenbau a 2W
DAC Server mit Netlas Karten, Notaus, DMX uvm.....
Akai APC40, Midi Keyboard for Live
Beam Table 2000 - Grating Box und Scanner Einheit, Audio gesteuert
Wohnort: Germany, Seefeld bei Werneuchen
Kontaktdaten:

Re: CNI PSU-III-OEM OP-Amp wird heiß

Beitrag von tracky » Do 29 Mär, 2018 5:33 pm

Die Regelstufe wird mit zwei Transistoren gemacht. Der erste Transistor geht direkt auf den Ausgang des OPV. Ich denke, das Problem wird ein Schwingen der Stufe sein. Normal wird der nur minimal warm. Problem wird wohl eines der "c's" in der Außenbeschaltung sein. Normal ist der LM358 auch nicht kompatibel von den Parametern mit dem AD8606. Löte mal die gelben Kerle nach, in der Hoffnung, dass sich keine Bondung am Kondensator löst. Zur Not habe ich auch noch komplette Treiber liegen.
Gruß Sven

Laser? Was ist das? Licht aus super erschwinglichen Restbeständen

Benutzeravatar
brathähnchen
Beiträge: 19
Registriert: So 20 Mai, 2007 7:45 pm

Re: CNI PSU-III-OEM OP-Amp wird heiß

Beitrag von brathähnchen » Do 29 Mär, 2018 7:47 pm

tracky hat geschrieben:
Do 29 Mär, 2018 5:33 pm
Die Regelstufe wird mit zwei Transistoren gemacht. Der erste Transistor geht direkt auf den Ausgang des OPV.
Genau so ist es. Ich habe mir den Schaltungsteil um den OP-Amp mal angesehen. Die eine Hälfte des OPs ist für die LD Stromregelung, die andere wohl fürs Blanking. Wobei mir noch nicht ganz klar ist, wie das überhaupt analog moduliert werden kann nachdem das Modulationssignal erst mal durch ein Gatter muss.
Schaltplan_AD8606.jpg
Der 2. Ausgang (Pin 7 des AD8606) geht direkt auf die Basis von U3. Finde ich nicht optimal gelöst und hab U3 einen 200 Ohm Vorwiderstand spendiert. Zumindest wird jetzt der OP nur noch ~80°C warm, der eigentliche Fehler wird es vermutlich nicht sein. Die max. 25mA sollte der AD8606 locker treiben können (Datenblatt: 80mA).
Was interessant ist, dass der OP nur warm wird wenn der Laser nicht moduliert wird. Ab 1V am Modulationseingang (und ~3mW grün) bleibt der OP kalt.
tracky hat geschrieben:
Do 29 Mär, 2018 5:33 pm
Ich denke, das Problem wird ein Schwingen der Stufe sein. Normal wird der nur minimal warm. Problem wird wohl eines der "c's" in der Außenbeschaltung sein. [...] Löte mal die gelben Kerle nach, in der Hoffnung, dass sich keine Bondung am Kondensator löst. Zur Not habe ich auch noch komplette Treiber liegen.
Den Bereich um den OP-Amp habe ich mal nachgelötet, hat leider keine Verbesserung gebracht. Muss wohl doch noch das Scope rauskramen...
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Benutzeravatar
tracky
Beiträge: 4757
Registriert: Di 11 Mär, 2003 1:51 pm
Do you already have Laser-Equipment?: RGB Projektor mit 2W 445nm, 1W 520nm, 1W 658nm Swisslas, Raytrack 30, Gento Safety für Grafik Shows
2x Venus 1800 RGB
2x Venus 3 RGB
2x Eigenbau a 2W
DAC Server mit Netlas Karten, Notaus, DMX uvm.....
Akai APC40, Midi Keyboard for Live
Beam Table 2000 - Grating Box und Scanner Einheit, Audio gesteuert
Wohnort: Germany, Seefeld bei Werneuchen
Kontaktdaten:

Re: CNI PSU-III-OEM OP-Amp wird heiß

Beitrag von tracky » Do 29 Mär, 2018 8:44 pm

Das Blanking wurde eigentlich über eine Referenzspannung realisiert. Hatte mal damals die TTL Treiber auf analog umgebaut. Lange her. Eigentlich solte der Leistungstransistor auch ein Darlingten Typ sein. Die Treiber können bis knapp 5A, je nach Shunt regeln. Standard sollte ein 0,33Ohm im TO220A sein. Leider kann ich die Schaltung nicht mehr finden. Ist wie gesagt schon Jahre her.
Gruß Sven

Laser? Was ist das? Licht aus super erschwinglichen Restbeständen

Benutzeravatar
brathähnchen
Beiträge: 19
Registriert: So 20 Mai, 2007 7:45 pm

Re: CNI PSU-III-OEM OP-Amp wird heiß

Beitrag von brathähnchen » Mi 04 Apr, 2018 6:14 pm

Hat leider etwas länger gedauert, dafür weiß ich jetzt: Ja, dass der OP heiß wird, kommt von CNI direkt ab Werk :shock:

Erst mal gemessen ob der OP schwingt. Nur an Pin 7 hat man etwas AC-Anteil gesehen:
Scope1_Pin7.png
Im Detail:
Scope2_Pin7.png
Hmm, 200mV bei 300Hz dürften nicht dafür sorgen, dass der OP heiß wird (keine Sorge, das ist ein 350 MHz Scope, HF erkennt man damit...).

Also weiter gemessen und Leiterbahnen verfolgt. Bei den Transistoren zur Ansteuerung der Stromquelle hat CNI auf der PCB eine Leiterbahn unterbrochen, hier habe ich mir den Schaltungsteil nochmals genauer angesehen und einen Fehler in der ursprünglichen Schaltplanskizze gefunden:
OP-Ausgang.jpg
In schwarz ist erstmal das, was vom Platinenlayout vorgesehen war (Entspricht dem Stand der ursprünglichen Schaltplanskizze).
In rot ist die Änderung von CNI. Die Leitung beim Kollektor von U3 ist aufgetrennt und mit einer Lötbrücke wurde der Kollektor direkt mit dem Ausgang (Pin1 von U1 / AD8606) verbunden. Natürlich wird dadurch der Ausgang auf GND kurzgeschlossen wenn kein Blankingsignal anliegt und der OP heizt.
Warum das gemacht wurde und ob das bei anderen Treibern auch so ist :?:

Deshalb meine Änderungen in grün, es wurde (falls es doch einen bestimmten Grund bei CNI für die Modifikation gab) die Lötbrücke durch einen 120 Ohm Widerstand ersetzt. Die Basis von U3 behält den 220 Ohm Widerstand von meiner ersten Modifikation. Auf der PCB sieht das so aus:
Mod Brathähnchen.jpg
Die jetzt fließenden 41mA sind zwar nicht wenig, allerdings noch innerhalb der Datenblattwerte und der OP wird nur 36°C warm. Damit kann ich leben. Vom Blankingverhalten habe ich optisch keinen Unterschied feststellen können. Den Diodenstrom beim Blanking habe ich mir noch nicht mit dem Scope angesehen, wenn der Laser aus ist fließen momentan ~125 mA durch die Pumpdiode. Grün oder IR wird nicht emmitiert.
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Antworten

Zurück zu „Dioden- & Festkörperlaser“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste