DPSS Lasertreiber Zickt...

Betrieb, Bau und Modifikation von Festkörper- und Diodenlasern (keine Pointer)
Antworten
Bunshee
Beiträge: 35
Registriert: Di 03 Jan, 2017 8:46 am
Do you already have Laser-Equipment?: 2W RGB Tarm, 2x 1W Grün Laserworld
Wohnort: Hannover

DPSS Lasertreiber Zickt...

Beitrag von Bunshee » Fr 17 Nov, 2017 12:04 am

Moin Jungs,

Habe diesen Lasertreiber für einen 500mW DPSS, dieser Zickt rum, bzw geht nun nicht mehr wirklich.

Mir fiel die Tage auf, das in einem meiner 3W Laser das Grün etwas sehr massiv schwächelte, dann fiel mir beim Programmieren einer Show auf, das Grün immer noch ein wenig leuchtet und nicht weg geblankt wurde, wenn Grün eigentlich hätte aus sein sollen.

Hätte jetzt viel sein können, hatte eigentlich die Scannersafety in verdacht und mir nichts weiter gedacht, wollte die am nächsten Tag ausbauen und musste feststellen das Grün garnich mehr an ging. So, Blanking Signal zum Treiber mittels Oszi war in Ordnung.

Dachte mir fu... der DPSS ist hinüber, Kopf von Treiber abgeklemmt, an ein Labornetzgerät angeschlossen, LD bestromt, lief....
Kopf wieder an den Treiber, Manuelles 5V Signal direkt an den Treiber, kein Erfolg.

Hab mir dann nun die mühe gemacht den Treiber aus meinem Doppelbodengehäuse auszubauen und mal zu messen, vom Netzteil auf den Treiber kommen die +5V, +12V und -12V (bzw. -11.89V)

Hab dann mal das 5V Signal an den Treiber gelegt und die Spannung zur LD gemessen, der Treiber gibt an LD+ und LD- lediglich 1.5V raus...
Wenn das 5V Signal am Treiber anliegt, leuchtet auch die RUN LED, die ERROR LED leuchtet nur kurz nach dem Anschalten was sie bisher immer schon getan hat.

Kennt jemand diesen Treiber?
Weiß jemand was am Treiber eventuell kaputt sein könnte, so das er nur noch +1.5V an die LD rausgibt?

Grüße, Daniel
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Grüße,
Daniel

2x 3.5W RGB, 2x 5W RGB, 1x 3.0W RGB, 1x Dual Projector (6.5W RGB * 2) 2x45K, Pangolin

Benutzeravatar
guido
Beiträge: 5970
Registriert: Do 20 Dez, 2001 12:00 pm
Do you already have Laser-Equipment?: Easylase, Netlase, Laser von 1..15W.
Entwickler von Dynamics + Mamba X4 .
Lasershow Hard / Software .
Wohnort: 32469 Petershagen
Kontaktdaten:

Re: DPSS Lasertreiber Zickt...

Beitrag von guido » Fr 17 Nov, 2017 5:57 am

Hi,

ein chinesischer Linearregler. Dem Kabelverhau rechts nach tippe ich auf 2 TEC´s im Kopf.
Durchpiepsen welcher Transistor für die Pumpdiode verantwortlich ist.
Die Shunts mal durchmessen, danach die Ansteuerung vom dazu gehörigem Transistor und natürlich selbigen.

Im Ansteuerzweig findest du diesen Analog/TTL Schalter. Was sich da hinter verbirgt ist
ein Bauteilegrab obwohl es ein popeliger Schmitt-Trigger auch getan hätte.

Mal auf TTL umgeschaltet was er dann macht ?
Mal alle Potis "freigedreht" ? Also ein paar mal +/-90 Grad zum Dreck verteilen :-)
Manchmal sind es ganz banale Fehler... vielleicht will er dir auch sagen das er einfach sterben möchte :-)

Benutzeravatar
tschosef
Beiträge: 7665
Registriert: Mi 19 Nov, 2003 10:27 am
Do you already have Laser-Equipment?: 5 Projektoren, teils eigenbau, teils gekauft... und "zubehör"
Wohnort: Steinberg
Kontaktdaten:

Re: DPSS Lasertreiber Zickt...

Beitrag von tschosef » Fr 17 Nov, 2017 7:12 am

howdy..
Mal alle Potis "freigedreht" ? Also ein paar mal +/-90 Grad zum Dreck verteilen :-)
jou.... hab ich mir auch grad gedacht... war auch bei meinem CNI Dpss Treiber gerne ein Problem... Oxidschicht am Poti... hat dessen Wert verändert... paar mal hin und her drehen, hat das Problem dann gern behoben.

woll ich beim Durchlesen deiner Problembeschreibung auch schon schreiben.. Guido war schneller :-)

viele Grüße
ERich
Schreibe nie etwas, was Du deinem Gegenüber nicht auch vor anderen Leuten ins Gesicht sagen würdest

Bin der Programmierer von HE-Laserscan
http://www.HE-Laserscan.de
Lasersoftware + Laserhardware

Bunshee
Beiträge: 35
Registriert: Di 03 Jan, 2017 8:46 am
Do you already have Laser-Equipment?: 2W RGB Tarm, 2x 1W Grün Laserworld
Wohnort: Hannover

Re: DPSS Lasertreiber Zickt...

Beitrag von Bunshee » Fr 17 Nov, 2017 10:51 am

Danke für eure Tipps mit den Trimpotis :D aber hat leider nichts bewirkt.

Beim messen wohin die LD geht, habe ich bei der Demontage des Treibers festgestellt, das eine der Schrauben der Mosfets nicht angezogen war.

Um die Frage zu beantworten, der Kopf hat nur 1 TEC, dabei ist mir aufgefallen, wenn ich TEC+ und TEC- messe, sind 0V vorhanden, wenn ich TEC+ gegen GND vom Netzteil messe habe ich +12V, kann, muss jetzt nichts heißen, da ich keinen vergleich, noch Schaltplan habe dazu habe :) aber lässt sich zur not über ein Wochenende Reverse Engineeren, da es zum glück nur eine Zweiseitige PCB ist...

Die Transistoren wo die LD hingeht, sind 2x Mosfets (IRF540N) Ich schätze einen für die TEC (noch nicht durchgepipst) und einen für die LD. Der nächste IC der kommen würde wäre der LF347, über dem schalter befindet sich nur ein NAND Gate, aber beim Umschalten tut sich leider auch nichts.

Ich werde dann wohl erstmal die IRFs wechseln, das wäre jetzt so mal meine erste Anlaufstelle, das die nicht mehr genug raus pfeffern, bin aber gerade noch am messen ;)

Edit:
Am LD IRF540, liegen auf Source 5.5V, auf Drain werden 1.55V ausgegeben, am Gate liegen 1.7V an..

Grüße,
Daniel
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Grüße,
Daniel

2x 3.5W RGB, 2x 5W RGB, 1x 3.0W RGB, 1x Dual Projector (6.5W RGB * 2) 2x45K, Pangolin

Benutzeravatar
masterlu79
Beiträge: 301
Registriert: Mo 24 Apr, 2006 10:23 am
Do you already have Laser-Equipment?: 1600mW 532nm von Laser Quantum 1,8mm Beam 0,5mrad gemessen und vieles mehr...

Re: DPSS Lasertreiber Zickt...

Beitrag von masterlu79 » Fr 17 Nov, 2017 9:33 pm

Huhu,
der Widerstand R63 sieht auch nicht wirklich gut gelötet aus!
Mal alles überprüfen was nachgelötet werden kann. Hilft oft Wunder.

LG Falk

Benutzeravatar
richi
Beiträge: 709
Registriert: Di 31 Okt, 2000 12:00 pm
Do you already have Laser-Equipment?: Seit 30Jahren Laser sammeln :-)
Wohnort: Bamberg
Kontaktdaten:

Re: DPSS Lasertreiber Zickt...

Beitrag von richi » Fr 17 Nov, 2017 10:36 pm

der IRF540 ist doch ein n-Kanal Typ d.h. die Source muss Richtung GND gehen.
Wo hängt die LD drin ? Zwischen GND und Source oder zwischen Drain und der Versorgungsspannung.
Von welchem Potential aus hast du die Spannungen gemessen ?
echte Freaks haben Gaslaser
- Gewerbliches Mitglied -

Bunshee
Beiträge: 35
Registriert: Di 03 Jan, 2017 8:46 am
Do you already have Laser-Equipment?: 2W RGB Tarm, 2x 1W Grün Laserworld
Wohnort: Hannover

Re: DPSS Lasertreiber Zickt...

Beitrag von Bunshee » So 19 Nov, 2017 3:05 pm

richi hat geschrieben:
Fr 17 Nov, 2017 10:36 pm
der IRF540 ist doch ein n-Kanal Typ d.h. die Source muss Richtung GND gehen.
Wo hängt die LD drin ? Zwischen GND und Source oder zwischen Drain und der Versorgungsspannung.
Von welchem Potential aus hast du die Spannungen gemessen ?
Du hast natürlich Recht, diese Info hab ich ausversehen verschwiegen :)
Ich habe zwischen LD+ und Source gemessen!

Habe aber in der Zwischenzeit den IRF getauscht, leider läuft der Treiber immer noch nicht.

Zwischen LD+ und LD- liegen 1.55V an, wenn der Kopf am Treiber hängt,
hängt er nicht am Treiber, liegen zwischen LD+ und LD- knappe 3V an.

Zwischen Versorgungsspannung GND und Source liegen +5V an, zwischen GND und Drain, Gate lagen 0V an.


Grüße,
Daniel
Grüße,
Daniel

2x 3.5W RGB, 2x 5W RGB, 1x 3.0W RGB, 1x Dual Projector (6.5W RGB * 2) 2x45K, Pangolin

Benutzeravatar
richi
Beiträge: 709
Registriert: Di 31 Okt, 2000 12:00 pm
Do you already have Laser-Equipment?: Seit 30Jahren Laser sammeln :-)
Wohnort: Bamberg
Kontaktdaten:

Re: DPSS Lasertreiber Zickt...

Beitrag von richi » So 19 Nov, 2017 3:22 pm

Die Gate Spannung muss in Richtung Drain gehen, damit der überhaupt leitet, bei deinen Spannungen die du hier angegeben hast dürfte da maximal ein Strom im µA bereich durchfließen. Der Fehler liegt in der Ansteuerung vom Mosfet.
echte Freaks haben Gaslaser
- Gewerbliches Mitglied -

Bunshee
Beiträge: 35
Registriert: Di 03 Jan, 2017 8:46 am
Do you already have Laser-Equipment?: 2W RGB Tarm, 2x 1W Grün Laserworld
Wohnort: Hannover

Re: DPSS Lasertreiber Zickt...

Beitrag von Bunshee » So 19 Nov, 2017 3:30 pm

richi hat geschrieben:
So 19 Nov, 2017 3:22 pm
Die Gate Spannung muss in Richtung Drain gehen, damit der überhaupt leitet, bei deinen Spannungen die du hier angegeben hast dürfte da maximal ein Strom im µA bereich durchfließen. Der Fehler liegt in der Ansteuerung vom Mosfet.
Habe ich gemerkt, habe diesen heute vormittag auch mal gewechselt, aber no way....
auch nochmal alles nachgelötet, aber auch ohne erfolg.

Die 5V Analogspannung liegen auch am Analogeingang an, wenn ich auf TTL+ und TTL- umstelle, bewirkt auch nichts...

Die Frage ist nun, ob Ich mir die mühe mache den Treiber in Eagle nach zu Zeichnen... oder was könnte ich spontan noch tauschen?
Hab im Internet aktuell keinen ähnlichen Linear Treiber gefunden... :(
Grüße,
Daniel

2x 3.5W RGB, 2x 5W RGB, 1x 3.0W RGB, 1x Dual Projector (6.5W RGB * 2) 2x45K, Pangolin

Benutzeravatar
richi
Beiträge: 709
Registriert: Di 31 Okt, 2000 12:00 pm
Do you already have Laser-Equipment?: Seit 30Jahren Laser sammeln :-)
Wohnort: Bamberg
Kontaktdaten:

Re: DPSS Lasertreiber Zickt...

Beitrag von richi » So 19 Nov, 2017 3:58 pm

U6 und U7 sind jeweils 4 fach OPs ? Verfolge doch einfach mal das Eingangssignal an den OPs
echte Freaks haben Gaslaser
- Gewerbliches Mitglied -

Bunshee
Beiträge: 35
Registriert: Di 03 Jan, 2017 8:46 am
Do you already have Laser-Equipment?: 2W RGB Tarm, 2x 1W Grün Laserworld
Wohnort: Hannover

Re: DPSS Lasertreiber Zickt...

Beitrag von Bunshee » So 26 Nov, 2017 7:25 pm

richi hat geschrieben:
So 19 Nov, 2017 3:58 pm
U6 und U7 sind jeweils 4 fach OPs ? Verfolge doch einfach mal das Eingangssignal an den OPs
bin jetzt erst dazu gekommen, mal genauer zu schauen und zu messen...

Also, U6 ist ein NAND 2-Quad Schmitt Trigger, U7, U5, U4 sind Ops / Jfets (LF347)

Hatte nun mal mehr Zeit um das Analog+ Signal zu verfolgen, das Analog+ Signal, geht zum U4 nach oben, habe mir mal die Mühe gemacht, die Platine zu Reversen und in Eagle zu zeichnen, vielleicht hilfts etwas... Plan ist jedoch an einem halben Nachmittag entstanden und könnte evtl. Fehler enthalten, oder bisschen Wirr sein, da ich noch nicht zum sortieren und schön machen gekommen bin.

Kurz:

1 Output vom U4 Op, geht runter zum Schalter, wird bei AIN an den Trimm-Poti neben dem Schalter durchgeschaltet (Eingestellt auf 6.5K) vom Trimmpoti Ausgang, gehts wieder nach oben über den U4, wieder runter mit einem Umweg zum U6 (Schmitt-Trigger) und von diesem über den U5 wo auch der Kondensator nachgelötet wurde, zum Mosfet...

Werde später eventuell noch ein paar Messungen machen und Posten ;-)

P.S. Die Bezeichnungen der Widerstände und Kondensatoren, passen mit der Platine überein, hatte ich nochmal kontrolliert, bis auf evtl. 2-4 Bezeichnungen, die TTL Schaltung habe ich mal weg gelassen, da nicht interessant...
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Grüße,
Daniel

2x 3.5W RGB, 2x 5W RGB, 1x 3.0W RGB, 1x Dual Projector (6.5W RGB * 2) 2x45K, Pangolin

Benutzeravatar
richi
Beiträge: 709
Registriert: Di 31 Okt, 2000 12:00 pm
Do you already have Laser-Equipment?: Seit 30Jahren Laser sammeln :-)
Wohnort: Bamberg
Kontaktdaten:

Re: DPSS Lasertreiber Zickt...

Beitrag von richi » Sa 16 Dez, 2017 6:03 pm

Ok jetzt erst gesehen, der Plan ist wirklich schwer zu lesen, aber bei reverse enginiering is das ja mal normal.

R26 hat wirklich 100 Ohm ? das macht keinen sinn da R25 und R42 plus W3 ja mind 20k dagegen stehen, was soll dann der OP U5C bewirken... seltsam, fehlt da vieleicht eine Verbindung ?

Ich gehe davon aus du hast dein Eingangs signal noch vollständig bei W1 oder ?
echte Freaks haben Gaslaser
- Gewerbliches Mitglied -

Bunshee
Beiträge: 35
Registriert: Di 03 Jan, 2017 8:46 am
Do you already have Laser-Equipment?: 2W RGB Tarm, 2x 1W Grün Laserworld
Wohnort: Hannover

Re: DPSS Lasertreiber Zickt...

Beitrag von Bunshee » So 24 Dez, 2017 4:10 pm

Hallo,

Ja R26 hat laut Widerstandstabelle wirklich 100 Ohm und hab das auch nochmal nachkontrolliert, ob ich mich evtl. vertan habe, oder das Routing falsch ist, habe aber zugegebener Maßen den Plan nochmals aktualisiert, da einige Routing falsch waren, aber die Verbindung R26, R25, R42 um W3 herum, war jedoch korrekt.

Muss den Schaltplan jetzt mal über die Tage ordnen und sortierten, habe erstmal angefangen die Leiterbahnen auf dem eigentlich Board nach zu Zeichnen, so habe ich noch ein paar Routing Fehler entdecken können.

Werde dazu mal über die Tage sämtliche Elko's austauschen, mal schauen, kann mir das nich wirklich erklären, da wie du bereits sagtest, würde kein Sinn machen, W3 hat jedoch 50k..

Eingangssignal geht vollständig über W1, wobei ich W1 nicht weiter gezeichnet habe, das der Rest TTL ist und mich nicht interessiert hat, daher geht das Analog Eingangssignal auch nochmal zu W1
Grüße,
Daniel

2x 3.5W RGB, 2x 5W RGB, 1x 3.0W RGB, 1x Dual Projector (6.5W RGB * 2) 2x45K, Pangolin

Antworten

Zurück zu „Dioden- & Festkörperlaser“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste